[FIXED] Character Icon Bug

View previous topic View next topic Go down

[FIXED] Character Icon Bug

Post  dreamsunder on Tue Oct 01, 2013 1:52 am

Hello, it seems I've encountered an odd bug while filling out a character profile. I chose the transparent 'water battle pet' icon to use, and now, my profile will no longer open. I can't access it to edit it, either, as every time I click on the TRP2 icon, a LUA error appears. I can still view others' profiles, but I'm unable to view my own, or edit it.
So far, I've tried uninstalling/reinstalling TRP2, clearing my cache, deleting all of my characters' info out of the WTF folder and 'sneaking in' through other peoples' profiles, but nothing seems to be working. I use a Mac, if that helps. The LUA error is copypasta'd below.

Message: ...ddOns\totalRP2_Interface\totalRP2_Interface_Main.lua:1144: SetPortraitToTexture(): image must be 64x64 pixels
Time: Mon Sep 30 23:34:56 2013
Count: 40
Stack: [C]: in function `SetPortraitToTexture'
...ddOns\totalRP2_Interface\totalRP2_Interface_Main.lua:1144: in function `TRP2_OpenPanel'
...ddOns\totalRP2_Interface\totalRP2_Interface_Main.lua:1066: in function `TRP2_OpenMainMenu'
[string "*:OnClick"]:2: in function <[string "*:OnClick"]:1>

Locals: (*temporary) = TRP2_PanelPortrait {
0 = <userdata>
}
(*temporary) = "Interface\ICONS\pet_type_water"

dreamsunder

Posts : 1
Join date : 2013-10-01

View user profile

Back to top Go down

Re: [FIXED] Character Icon Bug

Post  Lixxel on Fri Oct 11, 2013 1:51 am

Hello! I guess some of the icons that were added just don't work as character icons and I'll have to figure out which Sad

In the mean time, I was able to replicate the bug and fix the issue with this simple macro:

/run TRP2_SetInfo(TRP2_Joueur,"Actu",{});
Let me know if that works for you too!

Lixxel
Admin

Posts : 17
Join date : 2013-02-05
Location : USA

View user profile http://trp2.forumotion.com

Back to top Go down

Re: [FIXED] Character Icon Bug

Post  Narex on Sun Oct 13, 2013 9:06 pm

I had the problem , your macro fixed it , but if change the Icon back to what i had , there is still a bug =/

Sorry for my bad english .

Narex

Posts : 1
Join date : 2013-10-13

View user profile

Back to top Go down

Re: [FIXED] Character Icon Bug

Post  Lady Kara on Wed Nov 20, 2013 9:36 pm

I had the same problem with the following icon :


To fix it, I've searched to TRP2 variables for the character and manually changed to name of the icon to another.
avatar
Lady Kara

Posts : 43
Join date : 2013-09-28
Location : Undercity - France

View user profile http://www.goblinounours.fr/tsglab/?icons_US

Back to top Go down

Re: [FIXED] Character Icon Bug

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum